Product Setup

To install Desktop Client, log into your computer with root permissions, and follow the steps below.

  1. Download the IBM Aspera product installer.
    Use the credentials provided to your organization by Aspera to access:

    http://downloads.asperasoft.com/en/downloads/2

    If you need help determining your firm's access credentials, contact your Aspera account manager.

  2. For product upgrades, ensure you have prepared your machine to upgrade to a newer version.
    Although the installer performs your upgrade automatically, Aspera highly recommends completing the tasks described in Before Upgrading or Downgrading. If you do not follow these steps, you risk installation errors or losing your configuration settings.
  3. Run the installer
    To run the installer, run the following commands with the proper administrative permissions. Replace the product version accordingly.
    # pkgadd -d /filepath/aspera-scp-client-version.pkg 
  4. For versions 9-11.2, install OpenSSH.
    Solaris 9 - 11.2 is installed with a version of SunSSH that is not supported by Aspera and you must install OpenSSH. See https://www.openssh.com and your OS manual for instructions.

    Solaris 11.3+ SunSSH is supported.

  5. Install the license.

    To install the license from the command line, create the following file:

    /opt/aspera/etc/aspera-license

    Copy and paste your license key string into it, then save and close the file. To verify the license information, run the following command:

    # ascp -A

    If you are updating your product license after the installation, see Updating the Product License.

  6. Troubleshooting
    If the installer freezes during installation, another Aspera product might be running on your computer. To stop all FASP transfer-related applications and connections, see Before Upgrading or Downgrading.
    If you receive the error message, "Current administration requires that a unique instance of the <ASPRent> package be created. However, the maximum number of instances of the package which may be supported at one time on the same system has already been met" this indicates that you have an Aspera package installed. Remove the exisiting package and install the new one by running the following commands:
    # pkgrm ASPRent
    # pkgadd -d /filepath/aspera-scp-client-version.pkg

Upgrade Follow up

  1. If upgrading and the Redis DB is run on another system: Update the KV store keys to the latest format.
    The local Redis DB schema is automatically updated by the installer, but non-local redis DB must be manually updated by running the following command as root:
  2. For all upgrades: Validate aspera.conf.
    The aspera.conf file is not overwritten during an upgrade and your configurations are preserved. However, the XML formatting, parameters, and acceptable values may have changed between your old version and new version. Run the following command to check aspera.conf for XML form and valid configuration settings:
    # /opt/aspera/bin/asuserdata -v