Setup

IBM Aspera Sync (the async and asyncadmin executables) is automatically installed with Enterprise Server, Connect Server, Point-to-Point, or Desktop Client version 3.5 or above, but requires a Sync-enabled license to run. IBM Aspera Sync must be installed on both the source and destination machines. For more information, see System Requirements. You must have permission to access the directories and files that are to be synchronized using Sync.

Important: If you attempt to sync a directory without the proper read/write permissions, the directory and files it contains are not marked with an ERROR flag in the file directory status output. However, the error will be noted in the log file.

Updates to Sync are available as patches that can be downloaded from the Aspera website. To install the patch, follow the instructions below.

  1. Download the update patch from Aspera from the following location:
    http://www.asperasoft.com/en/downloads/23

    If you need help determining your firm's access credentials, contact your Aspera account manager.

  2. Extract Sync files and binaries .
    # tar -xvf aspera-sync-version-operating_system.tar

    Replace the existing files and binaries in /opt/aspera with the extracted files.

  3. Verify the async and asyncadmin installations.
    Run the following commands in a terminal window:
    # async -A
    # asyncadmin -A

    Messages similar to the following messages appear if installation was successful:

    # async -A                    <!-- Check Aspera product license -->
    Aspera Enterprise Server version version
    async version version
    Operating System: platform
    FIPS 140-2-validated crypto ready to configure
    License max rate=(unlimited), account no.=1, license no.=12345. Expiration date: expiration_date
    
    # asyncadmin -A                <!-- Display software version -->
    Aspera asyncadmin version version